C语言的简易编程问题Your task is to Calculate the sum of some integers.InputInput contains multiple test cases.Each test case contains a integer N,and then N integers follow in the same line.A test case starting with 0 terminates the input an
来源:学生作业帮助网 编辑:六六作业网 时间:2024/12/24 08:22:13
C语言的简易编程问题Your task is to Calculate the sum of some integers.InputInput contains multiple test cases.Each test case contains a integer N,and then N integers follow in the same line.A test case starting with 0 terminates the input an
C语言的简易编程问题
Your task is to Calculate the sum of some integers.
Input
Input contains multiple test cases.Each test case contains a
integer N,and then N integers follow in the same line.A test case starting
with 0 terminates the input and this test case is not to be processed.
Output
For each group of input integers you should output their sum
in one line,and with one line of output for each line in input.
Sample Input
4 1 2 3 4
5 1 2 3 4 5
0
Sample Output
10
15
Sample Input
2
4 1 2 3 4
5 1 2 3 4 5
Sample Output
10
15
C语言的简易编程问题Your task is to Calculate the sum of some integers.InputInput contains multiple test cases.Each test case contains a integer N,and then N integers follow in the same line.A test case starting with 0 terminates the input an
#include <stdio.h>
int main()
{
bool newlineok=false;
int n,a,ans,i;
while(true)
{
scanf("%d",&n);
if(n==0) return 0;
if(!newlineok) newlineok=true;
else printf("\n");
ans=0;
for(i=0;i<n;i++)
{
scanf("%d",&a);
ans+=a;
}
printf("%d",ans);
}
return 0;
}